Run SYSTM and BOLT together

I’m running SYSTM on iphone. I like to see various metrics on my BOLT which aren’t available on the SYSTM screen. However I can only have either SYSTM or BOLT to show power, so looks like only one thing at a time will connect to the KICKR. The BOLT is set correctly to run from third party source. I can get an old Garmin to work like this so my thinking is it’s something to do with the BOLT and SYSTM fighting it out for access to the Bluetooth connection. Any help would be appreciated.

1 Like

Hi Ian, and welcome!

My guess is that the BOLT tries to control the KICKR at the same time as the SYSTM software tries to control it. Even though you only want it to read stuff. That surely is confusing at least one - if not all - of the three devices.

EDIT:
That was nonsense - it can do it on a Windows operated app, no clue why it won’t work for you @Ian_Jackson.

So my comment can be deleted from the minutes. Apologies.

Hi @Ian_Jackson welcome to the forums.

Can you confirm which Bolt you’re using (not that it should matter). The original one or the more recent (this year, black) ‘v2’ ?

I have spent a lot of time this year with Sufferfest, SYSTM, kickr and both Bolts, dual/treble and quadruple recording (had some cross platofrm testing to do).

It has worked this year for me, so let’s see if we can get to the bottom of it.

Ideally, you want SYSTM to use One of BT or ANT and then get the bolt to use the other.

As you’re using an iPhone that’ll be SYSTM to Kickr via BT and then get the bolt to pick up the ant signal from the trainer.

Some what irritatingly I have just swapped ona different trainer just now (which also has BT and ANT) (kickr is away temporarily) so I can’t prove it for the kickr just now.

What I’ve got here though is a v2 bolt and just hooking it up during this workout to see what happens.

  • I have a workout in progress (trainer controlled by BT on ERG)

  • bolt v2 running and searching for the trainer.
    At this point I’m being offered only my trainer on ANT and when I select that ANT connection I’m getting power etc to the bolt.

When you do the ‘add sensor’ thing on the bolt what do you see?
(It might be an idea - if the trainer is connected by BT to the bolt already - to disconnect that tod the device connections - then connect SYSTM to the trainer via BT - then readd the Kickr to the bolt but make sure you use the ‘more’ button in case you have a choice of BT or ANT and select ANT)

Make sure the BOLT is set NOT to control the trainer. I once figured out how to do that and it wasn’t hard, but I don’t remember.

Also: make sure to update firmware on the KICKR and BOLT if it’s been a while

1 Like

Not to repeat what’s already been said, but if you have SYSTM controlling your trainer, you can put your BOLT in passive mode to still display power and other metrics.

1 Like

Hi thanks for response. I’m on a 2 year old Bolt. I’d figured one needs to be on Bluetooth and one on Ant+ but struggle to pick up Ant+ on the BOLT. It picked up for a few seconds but dropped out. Thought might be Ant+ issue with BOLT but I can run it with GARMIN ANT+ sensors outdoors. Ant+ on KICKR is ok as my Garmin Edge can pick that up. Seems the Bolt always wants to revert to Bluetooth and there’s no way of ‘forcing it’ to Ant +

The bit about Bluetooth is spot on - the firmware (as i understand it) is designed to be quite aggressive in looking for BT rather than ANT.

So it might help if the kickr is always connected first, and only then connect the bolt.
I was messing around earlier and I also found it a bit hit and miss ‘seeing the ANT connection on the Bolt pairing screen.

Hopefully once it’s connected properly once it’ll stay connected for you !

Thanks Martin it sounds like it’s just not me. I’ll have a play with it again today.