Power and cadence drops

Hello everyone,

I landed on the planet Sufferlandria over a year ago, following the purchase of a Wahoo Kickr v5.

Below are two screenshots from my Strava account. They are related to the same workout (Defender), the first one from the end of March this year and the second one from the end of November (last Sunday). You can clearly see drops in the power and cadence, as well as much more variation on the speed.

There is strictly no difference in my overall setup since March (Wahoo Kickr v5 + Windows 10, identical room and bike, no interference from other electronics) except for this migration to Wahoo SYSTM. Note that I check for updates regularly.

Any ideas on what might be wrong ?

Thanks for your help.
Orion

You notice that in november your connection (BT or ant) was very unstable. hence the difference.

Pozdrawiam
Jacek

Hi Jacek.

My PC and the Kickr are indeed connected via bluetooth. My hear rate monitor is connected via ANT+ (USB dongle). But this was already the case in March…

Bluetooth problem on the transmitter side then ? In that case, I suppose the Kickr Direct Connect (just released, what a coincidence) would solve it.

I haven’t read all the posts but has anyone had a similar experience ?

FWIW, you may disable BT in your phone during your next workout. It might be some app in the background that is trying to communicate with kickr and thus interfering kickr’s connection to pc.

It’s in Airplane mode with both Wifi and Bluetooth disabled… :unamused:

Do you see the same thing if you look at the workout in SYSTM? Do you feel the dropouts or is it just the recording?

Two suggestions: completely deinstall the SYSTM app and reinstall it. If that doesn’t work, contact customer support.

Yes, same thing in the SYSTM app (screenshot of Found in America) :

I don’t feel the dropouts at all.

I’m going to uninstall everything and reinstall. :crossed_fingers:

Thanks for your help :pray:

1 Like

Let us know if the deinstall/reinstall works. Good luck.

Also, BTLE is really sensitive to Wi-Fi interference, Are you connecting via Wi-Fi and is it possible to move to a 5GHz channel for that service? Doing just that has solved many dropout issues with Wi-Fi.

1 Like

Are you 100% sure about this? New android is tricky about BT and Airplane mode when some BT devices are connected prior to switching on Airplane. I would check manual BT switch off (without turning on airplane mode).

1 Like

*** UPDATE ***
I completed today’s workout by using an Ethernet cable instead of Wifi :

Much better, thanks @jmckenzieKOS :+1:

Tomorrow I’ll try it after uninstalling and reinstalling the PC application.

PS : @macnuts it’s an iPhone and I’ve made sure that the wifi and bluetooth are disabled.

Glad you’re making progress. Still alot of dropouts, though.

1 Like

I have SYSTM now for a few days…did the on location Gorges La Nesque…I used a Wahoo Kickr trainer purchased Sept 2021.
Ride on ERG mode. When there was a change in power or cadence…it seemed that trainer ? did not kick in in a direct way resulting in drops power as well as cadence, sometimes cadence dropped without a reason from 100 to 45 rpm & back up. Experienced similar issues during your rides?

@Werner That’s not supposed to happen. I have a similar vintage (i.e. new) KICKR and have never had a dropout or experienced any weird recordings that don’t reflect what I’m actually doing on the bike. Maybe there’s a problem with the KICKR or maybe something in your setup. What device are you running SYSTM on, and what sensors do you have connected?

I use the HRM TICKR, ant+ & bluetooth, this one has also some strange drops for longer times & after minutes or longer back to my normal heartrate…even in Strava. I changed a few times batteries without result. Other times HRM works fine. I use a tablet Samsung S7 running on Android…both purchased Sept 2021. Maybe ? an interference between the different devices ? Any ideas ? I was planning to go tomorrow to the shop for another hrm but maybe there is just nothing wrong with it…thanks for your intervention

Strava is a result of my workouts in Zwift

I have three suggestions, but low confidence they will work. But none are hard or time consuming to do.

First, I’d try to connect everything with Bluetooth if you have a choice. I think it’s a stronger signal than Ant+.

Second, I’d make sure to completely shutdown the Wahoo app (not SYSTM—the one you used to set up your KICKR and TICKR). Also shut down Strava or anything else that might be competing for the signals from the various sensors.

Third, deinstall and reinstall SYSTM. it seems like updates don’t always load automatically.

If none of that works and you count think of anything else to try, contact Wahoo customer support. I’d start with the SYSTM support folks, it the problem might in the equipment too.

Thanks for helping me out guys.
I think I solved the problem.
I did an update firmware of my TICKR X & my KICKR trainer.
This update seemed to have overruled the existing bugs @ first view. Keep you informed if anything will change.
Since both devices were just new I didnt suspect an update was key to my issue.

2 Likes

Final update: I uninstalled Wahoo Systm but also The Sufferfest which was still on my computer.

I re-installed Wahoo Systm and, oh magic, no more dropouts !

Thank you all for your help, appreciated