iPhone always grabbing BT connection with KICKR

I have a KICKR’17 and every time it power up it connects directly to my phone, via Bluetooth, stealing the connection from my Mac, where I run the SUF.
The interesting part is that there is no “info” button under iOS BT menu to disconnect it, so the only way it sto put the Phone into AirPlane mode and turn off BT.
This happens even if the phone is in a different room or in the house if that matters.

Does anybody know a good way to prevent the automatic connection in the first place?

‘Forget device’ not working for you?

And air plane mode is not needed, if you just switch off BT on your phone and then fire up your Mac and let it connect, no?

1 Like

Exactly. Settings -> Bluetooth -> (i) next to device -> Forget this device

@Cyclopaat and @titanicus: Please look at his screenshot. There is no (i) icon next to the device. For some reason it’s missing.

@ZenTurtle: I’m sorry, I have no answer for you. Maybe the minions can help? Did you write them an email ( theminions@thesufferfest.com)?

3 Likes

Good spot. Sorry I missed that first time.

@ZenTurtle: I don’t know if it works, but you could try resetting your network settings.

Go to settings > general > reset > reset network settings.

This way your phone will forget all bluetooth and wifi connections. Careful: You need to reconnect everything and type in all passwords again!

Did you ever connect your Kickr to the phone? Do you have the Wahoo App installed?

Still, switching off Bluetooth surely frees your Kickr to be hooked up to your Mac?

If not, I’m even more at a loss. I sometimes need my Neo’s BLE to connect to my Mac, but I usually use my phone to control it, and I’ve never had a problem like this.

Sorry for not seeing the missing :information_source:

Have you got the Wahoo app installed?

I think I had a similar issue with a tickr HR strap, that meant i had to uninstall the Wahoo app to stop my phone grabbing the connection from my laptop.

2 Likes

Once I “forgot” the KICKR from the Wahoo app, it also disappeared from the Bluetooth list. So it seems that the Wahoo app forces the pairing (even if it is not running in the background), which is silly.

This is probably one of the biggest frustration for people with multiple devices: I sometimes run Zwift or SUF on the iPad, sometimes on the Mac, and in some cases, like at the gym (back in the day when those existed), on my phone

Yes, that’s a workaround, but I’m an engineer and workarounds are not acceptable: fix what’s broken is the mantra :wink:

4 Likes

I agree, but what baffles me, is that you cannot ‘forget’ the device. I’ve yet to find a device that does that and I have (had) many devices paired to my phone. Bluetooth sometimes has quirks, especially when used with your car, which you share with your partner, etcetera, but that thing with you Kickr…

1 Like

@ZenTurtle, if you unplug your trainer, the (i) should appear next to the trainer on the list. You should then be able to forget the sensor. You can’t forget a connection that is active.
I have the Wahoo app installed, and even with the Wahoo app open, my Kickr (and other wahoo connected devices) do not appear in the Bluetooth menu, so I’m not sure why yours is appearing there. If you can’t get it to disconnect, can you please send us a help request? theminions@thesufferfest.com

3 Likes

I definitely experienced the same problem as the original poster. When disconnected and not in use, the trainer would NOT show in the list of disconnected Bluetooth devices. Then, when connected, it shows with the (i) icon and you cannot “forget” the device. The only solution I had was to delete the Wahoo app.

3 Likes

@tunatornado thanks for letting us know you’re having this issue. That’s really interesting as the Kickr isn’t appearing in my connected Bluetooth on my device at all. If you reinstall the Wahoo app, does the issue reproduce itself?

1 Like

I am having the same problem. My iphone seems to randomly connect to my Wahoo Kickr and, in doing so, disconnects my MacBook, frequently in mid-workout. Much like the OP, when I go to the list of Bluetooth devices on my iPhone, the option to “disconnect” or “forget this device” is missing for the Wahoo connections. Was this issue ever resolved?

Hi @BugDoc - welcome to the forum !!

Can you help with what steps you’ve already tried? (Or just rule out these ones …)

With the Kickr switched off, can you open up your Bluetooth list and permanently remove the kickr from the list? (I don’t think there’s a need to have the KICKR paired to the phone - I’ve just rechecked my BT list and I use the Wahoo app, I use SUF, and various other apps, but there’s no sign of the kickr on the list)

OR - does the kickr only appear in the list when you run a specific app or something? If so - which app?

Which KICKR version do you have (just in case)

Sorry - few questions in there - it helps us understand what the setup is.

M.

THanks for the reply

The Kickr only shows up in my Bluetooth list when it is turned on; it disappears when I unplug the Kickr. When it is turned on, there is no option to remove it from the list

.

It shows up on the list every time the Kickr is turned on, even when there are no apps running in the background at all.

I have the Kickr Snap trainer.

How odd. I’ve just turned my KICKR (2020) on and it doesn’t appear in that list without without the Wahoo app for example.

Was it ever paired directly do you know? (that’s only interesting as it helps pin down why it’s there in the first place which may help with disconnecting)

There are internet articles about removing the app that the device has been paired with in the past and seeing if that removes it from the list (ir if the device was paired via one of the many tacx/Wahoo/SUF apps or something) so that might be worth trying

I’ve also seen some info about work profiles existing in settings if it’s a work device that might affect ability to have the (i) button. But I’m not sure how that works.

Either of these things might be worth exploring.

Sounds like the iPhone in question is not behaving as we would expect.

If BT is switched off can you then do workouts in another device with the iPhone unable to grab the SNAP? (Workaround only obvs)

Thanks for the speedy reply. Nope, it was only ever paired through the Wahoo app and never directly to the phone. I will try deleting and re-installing the Wahoo app to see if that makes a difference.

It’s a personal phone so unlikely that any work-related settings would affect it. That said, I do have my work email and other apps on the phone (MS Office) so it’s possible that they may be doing something weird… but it seems odd that it would only affect specific bluetooth devices.

I have noticed that my Garmin HR monitor also randomly shows up in the Bluetooth list and similarly is missing the (i) button.

When BT on my phone is switched off, everything else behaves as it should. The Kickr, cadence sensor, and HRM all pair via BT with my MacBook and I can work out without any issues. The only problem is that I can’t stream music from my phone through my BT speaker, which isn’t the end of the world.

Just seems weird that the iPhone seems to be able to hijack BT connections and then refuse to relinquish control!

2 Likes

Make sure the Wahoo app is closed. Even if it’s just open in the background it can hijack your kickr.