Half Monty is killing music from Bandcamp

Im on Ipad.

Start music on Bandcamp, come back to Half Monty, music dead. It seems that this is super duper special to Half Monty because I can do other suff workouts with the MUSIC switch set to OFF and Bandcamp will still play.

I tried to turn the SOUND EFFECTS switch to OFF in Half Monty (there is no MUSIC switch) hoping that this is the magic bug fix but this kills the music as well.

This is an iOS issue. It didn’t happen with the SUF app, but happens with the SYSTM app. I have this problem with every music app i’ve tried on my iphone:

Apple Music, Spotify, Pandora, Perform, Amazon Music, and some others.

@emacdoug Did you submit a ticket on this? I remember you saying you did. A ‘dogpile on the rabbit’ might be a good thing to raise the level of concern.

2 Likes

have you tried the suggested troubleshooting steps here:

1 Like

Specifically, open another workout and toggle music off, play the vid ( even for a second or two.), pause, delete, Start Half Monty (but dont hit play yet), , open your music app, start your music app, return to SYSTM, start Half Monty.

Works for me in iOS on iPhone.

Edit: I think the newest app version “remembers” your music off (or on) settings.

All the above workarounds are ok for workouts where there is music. On no-vids or HM, there is no music switch in the app to set, so you can’t use a music app on the iPad and SYSTM at the same time.
I’ve raised this with support, and there’s no fix at this time.

2 Likes

@Glen.Coutts noting up from that I play music off my phone, to the side, specifically to avoid this kind of compatibility mess, this seems…less than ideal? :thinking:

Oy!

1 Like

RichardK,

I was just going to say the same thing, I cant turn the switch off because there is no switch. Honestly, this bug has got to quite simple to squash. Whatever gets called when a music switch gets turned to OFF, call it right at the beginning of Half Monty or whatever workout doesnt have a music switch. That’s the basic psuedo-gist :). (Im a programmer, I know that nothing really is ever “easy”)

@botski @RichardK …Obviously not ideal but have you tried my suggested workaround though, in the meantime, while the exterminators get after the bug?

I can get it to work every single time in iOS whether it’s the NoVid or the Half Monty.

Edit: NOT the support site workaround, but the one where you open any other vid that has the Music toggle, toggle it off, play, stop, delete, then do your NoVid or HM with any music you want.

1 Like

Glen, your suggestion works for workouts that have the music switch. But workouts that DONT have the switch cant use your suggestion because they dont have the music switch.

You do, however, imply that HM does indeed have a music switch. Can you verify? Because mine on IPAD does not.

1 Like

Sorry, I must not be being clear. I know that the NoVids and the HM don’t have the switch. I’m saying that doesn’t matter. If you open a vid WITH the switch and turn the switch off, play the vid for a second or two and delete it, then, when you open any no vid or HM then whatever thing is built into the app code behind the scenes will remember the setting and allow you to play music with HM or the NoVid.

AHHHHHHH!!! I get what you are saying now.

It still doesnt work for me. I listed your steps below. At step 8, returning to SYSTM, the music stops. Im using Bandcamp, not sure if that is the issue.

  1. Specifically, open another workout and toggle music off
  2. play the vid ( even for a second or two.)
  3. pause
  4. delete
  5. Start Half Monty (but dont hit play yet)
  6. open your music app
  7. start your music app
  8. return to SYSTM

NYET MUSIC

  1. start Half Monty.

That way works for me but you might need to start your music app first and start the music, THEN go back to HM.

I’ve found the only way I can get music to play during a No-Vid (and i’ve gotten to it work almost every time without fail) is this:

  1. start No-Vid
  2. start playing workout
    while riding the warm up:
  3. switch to music app and start music
  4. switch to SYSTM app
  5. music immediately stops playing
  6. repeat steps 3 and 4 approximately between 4 and 6 times until step 5 doesn’t happen.
  7. when step 5 doesn’t happen, ride the rest of my No-Vid while listening to my music, but…
  8. Don’t leave the SYSTM app, otherwise I will have to repeat step 6 again.

It’s a pain, but it works every time. If it works on the 5th time it should work the 1st time. I have no idea why repeating it would make it work. But, it does. :man_shrugging:

1 Like

I submitted a bug ticket and recommended they just put the music switch on every workout, no matter if the workout actually has music, and all would be well.

3 Likes

“easy”, sure. Whether your code will compile or not is another question. “There are 10 kinds of people in the world…”

:wink:

1 Like

Those that understand this is a ternary joke?

1 Like

There are 2 types of people in this world:

  1. Those that need closure,
3 Likes

Don’t keep us waiting, man! What’s the other one?

3 Likes

This made me think hard about laughing. Just had 4 wisdom teeth removed a couple hours ago, so real laughing isn’t in the cards

2 Likes