Garmin training load no longer updating

My garmin training load is no longer updating, since the update to SYSTM. Anyone else?

4 Likes

I noticed this too. My permission is for the sufferfest, perhaps we need to create a new one for systm?

Hmm, not sure! The activity synced no problem, just no updates to training status like it used to.

This is a Garmin thing. They’re likely on the backfoot with the app change and need to press some switches at their end

This one really bums me out. My first ride on Systm was awesome…but Garmin thinks I was eating donuts because it won’t transfer training load. Back to double recording, I guess…

3 Likes

I have the same problem :weary:
It mess up my training load… I guess I have to go back to double recording (which I load).
Hope the guys will fix it soon

1 Like

I’ve stopped taking any interest in what Garmin says about Training Load or Fitness or anything like that as it all seems to be a bit of a budge and I now use a totally different app altogether to tell me how I feel but it also includes information I give it about my sleep, muscles being fatigued or what my RPE was yesterday, honestly how can you be unproductive for a week if your still doing 2/3 workouts and getting good results, it makes absolutely no sense at all.

I too hope that this functionality will be revived soon. No big issue, but it worked fine and from this point of view it is sort of regression bug (https://www.dcrainmaker.com/2021/06/garmin-training-status-now-includes-zwift-trainerroad-the-sufferfest-and-tacx-app-workouts.html).

Another thing I’ve noticed (for any Runalyze users): my workouts used to go Sufferfest > Strava > Runalyze, but now they only go as far as Strava. I guess this is ultimately a Strava issue, but it shows they’re not pushing the same data as they used to.

Back to recording on the Edge for me!

Garmin have removed systm/sufferfest from the list of third party apps that will update training status. They are saying it is a wahoo issue.

https://forums.garmin.com/apps-software/mobile-apps-web/f/garmin-connect-mobile-ios/275069/sufferfest-trainerroad-zwift-not-contributing-to-training-status

I hope this isn’t a return to double recording

2 Likes

Just came to post about this…

IMO a very unprofessional (series of) posts from “Garmin-Kevin” that reflects poorly on Garmin’s customer service.

Regardless, I’m interest on the background to this - I’d have assumed it’s a simple backend API key or bit of code that needs updating (SYSTM and/or Garmin end) to reflect the rebrand (which it what is what is for all intents and purposes from a Garmin perspective) to revive this. What I REALLY HOPE ISN’T THE CASE is that it has deliberately not been re-enabled Garmin-side to due to Wahoo being a competitor in the hardware space - I mean, surely not right, Wahoo have owned Sufferfest for how long now (and, notably since before this integration went live a few months ago)… surely Garmin can’t have only just noticed!!!

Keen to hear a quick soundbite from @David.McQuillen.KoS on this, ideally ending with a “yup we’ll get this switched back on again soon enough” - thanks in advance.

Really sad to see this functionality gone. If this is the beginning of a "turf war" between Garmin and Wahoo it does not look good for my SYSTM subscription. As someone who has significant investments outside of the Wahoo ecosystem (as in I do not currently use any Wahoo products - I did pick up the free TICKR when offered but gave it away because I never took it out of the box) I valued having the Sufferfest work flawlessly with the products I owned. If I can no longer count on that I will be looking for another option.

And, yes, I know that the Training Load calculation is new but it was my #1 complaint and Garmin fixed it finally stopping the dreaded double record.

Hope this gets fixed soon…

2 Likes

I’ve been working with Garmin and internally on this. Can anyone on this thread help me verify if it is working again? I think you’d have to do a ride in SYSTM, share to Garmin and verify on your Garmin watch that the training status reflects the ride.

In our switch to SYSTM, we changed the manufacturer ID in the .fit files we send from The Sufferfest to Wahoo Fitness. My hunch is that Garmin filters on that ID and that’s why it broke. I’ve reverted the ID to The Sufferfest and I can now see my SYSTM ride on my Garmin 945 as my last ride. I’ve also asked Garmin if they can add the Wahoo Fitness manufacturer ID to their list. But for now I don’t think it hurts anything to have the manufacturer ID set as The Sufferfest. I don’t know that any other service uses it.

7 Likes

We also are working on an issue where connecting your Garmin account to SYSTM is failing. I don’t know why that started failing or when we’ll have a fix but we are making some progress.

4 Likes

Yes I noticed after this morning’s session that I have both my Garmin ride details as well as that synced from Systm showing up in training load - whereas only the Garmin ride details had been showing up since the switch across to the Systm app from the Sufferfest app.

I’ll need to wait for a couple more rides before it actually reflects on my training status - I don’t have a power meter and Garmin requires two(?) rides using power, so that is why I wanted the System sync to again work fully on Garmin Connect.

Fingers crossed it is all working again, and thanks so much for your effort with this.

2 Likes

@reid.weber i disconnected my garmin account at the start of all this thinking that repairing the accounts would fix. I can’t link them for the reasons of your second post to test the fix in your first post but thank you for working on a fix for it

Hello @reid.weber, I did two workouts today and training load was registered in Garmin Connect so it looks like it is working again. Thank you :+1:

2 Likes

We figured out this bug yesterday. It was failing every time. It is a little better now in that it goes through about half the time but we’re working on a fix today that should make it work every time. You could try connecting a few times and it might work. Or just wait until next week once we’ve fixed it.

3 Likes

Hey Reid, really appreciate you guys tracking the forum and being so responsive :+1:

Keep up the great work :smiley: :swimming_man::biking_man::running_man:

3 Likes

It’s working again for me as well. Big thanks to everybody who made this quick fix possible!