Download dead

Hi Lisa,
I thought about this option too, but currently I’m really reluctant to delete the SUF app. It’s my last fallback, and as a minimum I have Blender and Elements of Style downloaded.
If I delete it and it will not solve my problem, I’m gonna be locked out from any kind of suffering on the bike for at least the rest of the night. I don’t even want to think about that…

Yes I can totally understand that. You can install SYSTM on your phone maybe as an alternative. Small screen contingency suffering? Not as good as big screen suffering but just as painful?

Installed it on an Android. And, lo and behold, it works! I can log in, play videos…
Problem here is, the Android version doesn’t offer video download yet, and in the torture chamber internet connection is somewhere between poor and not existent.
So this won’t help me suffering, unless I pick a no vid workout.
On the other hand it proves that it’s not an account or password issue. It seems like my Mac cannot link to the Wahoo servers any more…

1 Like

That is outstanding news on the android thing.
Very very long Ethernet cable ? :slight_smile:

Odd re MacBook.

Mac software up to date? So glad it works, yay!!! Worth getting in touch with the Minions to see if they can fix the Mac issue in the meantime.

There’s supposedly a new software update for the Mac coming soon, I got a few notices on Sunday to update mine even though it had the latest software think it’s now going to Sahara 12 ??? Or something 12

Either way, I’ll go to the chamber now.
I’m somewhere between doing Chasing Legends, which is scheduled for today, on the Android without video, or using the SUF on the Mac and ride Elements of Style instead…

Thanks all! I’ll keep you posted.


So for all who might still be interested, here is how this played out:
I updated my OS to Catalina. No further, not Big Sur. I wanted to take one step at a time.

After the update I started SYSTM and had the same problems as before.

I deleted it from my Mac and re-installed it. Problems were gone. I could log in, download, play videos, all good.
I had tried this on my old OS as well, to no success, so the OS played SOME role in this.

SUF was still installed, so I started it to see if I can download videos there as well. That failed. After I started SUF, I went back to SYSTM, and I had the same problems as before. I was still logged in, but I could not download videos any more. After an OS reboot, everything in SYSTM looked like I do not have a valid subscription. The app still knew my name and my account, but when I tried to download, it told me I should start the 14 days trial to be allowed to do so. I logged off, and when trying to log back in, that was not possible any more. Back at square one.

So, I deleted SYSTM again, re-installed again, and it worked again.

To summarise all this, I do not think it was primarily an OS problem. The outdated OS played a role in it, I have no idea what was going on there in the background. But even on Catalina I could reproduce the problem. It must have to do with running SYSTM and SUF in parallel.

Anyway, my setup now is stable, at least as long as I don’t touch SUF. I will keep it sitting there on my harddrive for a few more weeks, just to be sure. Come November, if I will face no further issues with SYSTM, I will eventually delete it.

Everyone you supported me here and came up with ideas how to solve my problem, thank you so much!
Great to have such a friendly and helpful community!

May you all suffer well!